On 8/26/24 20:47, Sami Tolvanen wrote: > On Mon, Aug 26, 2024 at 10:42 AM Petr Pavlu <petr.pavlu@xxxxxxxx> wrote: >> On 8/15/24 19:39, Sami Tolvanen wrote: >>> [...] >>> +int main(int argc, const char **argv) >>> +{ >>> + unsigned int n; >>> + >>> + if (parse_options(argc, argv) < 0) >>> + return usage(); >>> + >>> + for (n = 0; n < object_count; n++) { >>> + Dwfl *dwfl; >>> + int fd; >>> + >>> + fd = open(object_files[n], O_RDONLY); >>> + if (fd == -1) { >>> + error("open failed for '%s': %s", object_files[n], >>> + strerror(errno)); >>> + return -1; >>> + } >>> + >>> + dwfl = dwfl_begin(&callbacks); >>> + if (!dwfl) { >>> + error("dwfl_begin failed for '%s': %s", object_files[n], >>> + dwarf_errmsg(-1)); >>> + return -1; >>> + } >>> + >>> + if (!dwfl_report_offline(dwfl, object_files[n], object_files[n], >>> + fd)) { >>> + error("dwfl_report_offline failed for '%s': %s", >>> + object_files[n], dwarf_errmsg(-1)); >>> + return -1; >>> + } >>> + >>> + dwfl_report_end(dwfl, NULL, NULL); >>> + >>> + if (dwfl_getmodules(dwfl, &process_modules, NULL, 0)) { >>> + error("dwfl_getmodules failed for '%s'", >>> + object_files[n]); >>> + return -1; >>> + } >> >> I see that libdwfl has also directly function dwfl_nextcu(). Would it >> make sense to use it to simplify the code? > > How do you propose using the function? This loop goes through multiple > input files, should we need them, and we iterate through all the CUs > in process_modules. I was thinking it could be possible to replace the code to traverse modules and their their CUs, that is functions process_modules() and process_module(), with dwfl_nextcu(). However, I now notice that more work is added in subsequent patches to process_modules() so this wouldn't quite work. I would then only suggest to change some function names in the current code. Function process_modules() is a callback to process a single module and so it would be better to name it process_module(). The present function process_module() actually processes a compilation unit DIE so I would rename it to something like process_cu(). On 8/15/24 19:39, Sami Tolvanen wrote: > +int process_module(Dwfl_Module *mod, Dwarf *dbg, Dwarf_Die *cudie) > +{ > + struct state state = { .mod = mod, .dbg = dbg }; > + > + return check(process_die_container( > + &state, cudie, process_exported_symbols, match_all)); > +} Mostly a minor suggestion too.. Looking at the entire series, state.mod ends up unused and state.dbg is only used in process_cached() where it could be possibly replaced by doing dwarf_cu_getdwarf(die->cu)? Removing these two members from the state struct would then allow to instantiate a new state in process_exported_symbols() for each processed symbol. That looks cleaner than changing state.sym and resetting some parts of the state as the function walks over the exported symbols. -- Thanks, Petr