On Mon, Apr 15, 2024 at 12:47:50PM +0200, Peter Zijlstra wrote: > On Thu, Apr 11, 2024 at 07:05:25PM +0300, Mike Rapoport wrote: > > > To populate the cache, a writable large page is allocated from vmalloc with > > VM_ALLOW_HUGE_VMAP, filled with invalid instructions and then remapped as > > ROX. > > > +static void execmem_invalidate(void *ptr, size_t size, bool writable) > > +{ > > + if (execmem_info->invalidate) > > + execmem_info->invalidate(ptr, size, writable); > > + else > > + memset(ptr, 0, size); > > +} > > +static void execmem_invalidate(void *ptr, size_t size, bool writeable) > +{ > + /* fill memory with INT3 instructions */ > + if (writeable) > + memset(ptr, 0xcc, size); > + else > + text_poke_set(ptr, 0xcc, size); > +} > > Thing is, 0xcc (aka INT3_INSN_OPCODE) is not an invalid instruction. > It raises #BP not #UD. Do you mean that _invalidate is a poor name choice or that it's necessary to use an instruction that raises #UD? -- Sincerely yours, Mike.