With this patch set libkmod is now using attribute cleanup. It's working here for me, but please give it a look. There are also some minor improvements, such as adding OOM checks. Lucas De Marchi (9): testsuite: Move test-alias to test-util util: Add cleanup attribute config: Use _cleanup_free_ util: use _cleanup_free_ on path_make_absolute_cwd() testsuite: add basic test for getline_wrapped util: Be OOM-safe and use _cleanup_free_ array: avoid duplicate code to reallocate file: use _cleanup_free_ module: use _cleanup_free and remove useless call to free() Makefile.am | 6 +- libkmod/libkmod-array.c | 38 ++++---- libkmod/libkmod-config.c | 62 +++++------- libkmod/libkmod-file.c | 8 +- libkmod/libkmod-module.c | 14 +-- libkmod/libkmod-util.c | 52 ++++++---- libkmod/libkmod-util.h | 7 ++ libkmod/macro.h | 1 + testsuite/.gitignore | 6 +- testsuite/rootfs-pristine/test-alias/correct.txt | 25 ----- .../rootfs-pristine/test-util/alias-correct.txt | 25 +++++ .../test-util/getline_wrapped-correct.txt | 6 ++ .../test-util/getline_wrapped-input.txt | 6 ++ testsuite/test-alias.c | 75 --------------- testsuite/test-util.c | 106 +++++++++++++++++++++ 15 files changed, 238 insertions(+), 199 deletions(-) delete mode 100644 testsuite/rootfs-pristine/test-alias/correct.txt create mode 100644 testsuite/rootfs-pristine/test-util/alias-correct.txt create mode 100644 testsuite/rootfs-pristine/test-util/getline_wrapped-correct.txt create mode 100644 testsuite/rootfs-pristine/test-util/getline_wrapped-input.txt delete mode 100644 testsuite/test-alias.c create mode 100644 testsuite/test-util.c -- 1.8.4.2 -- To unsubscribe from this list: send the line "unsubscribe linux-modules" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html