On 3/22/23 02:25, Paul Cercueil wrote:
Le mercredi 22 mars 2023 à 12:18 +0300, Sergei Shtylyov a écrit :
On 3/22/23 12:07 PM, ye.xingchen@xxxxxxxxxx wrote:
From: Ye Xingchen <ye.xingchen@xxxxxxxxxx>
Replace the open-code with dev_err_probe() to simplify the code.
Signed-off-by: Ye Xingchen <ye.xingchen@xxxxxxxxxx>
---
drivers/mmc/host/jz4740_mmc.c | 5 +----
1 file changed, 1 insertion(+), 4 deletions(-)
diff --git a/drivers/mmc/host/jz4740_mmc.c
b/drivers/mmc/host/jz4740_mmc.c
index 698450afa7bb..a6ad03b24add 100644
--- a/drivers/mmc/host/jz4740_mmc.c
+++ b/drivers/mmc/host/jz4740_mmc.c
@@ -232,10 +232,7 @@ static int
jz4740_mmc_acquire_dma_channels(struct jz4740_mmc_host *host)
if (!IS_ERR(host->dma_tx))
return 0;
- if (PTR_ERR(host->dma_tx) != -ENODEV) {
- dev_err(dev, "Failed to get dma tx-rx channel\n");
- return PTR_ERR(host->dma_tx);
- }
+ return dev_err_probe(dev, PTR_ERR(host->dma_tx), "Failed to
get dma tx-rx channel\n");
I'm afraid this makes the following code unreachable...
Also, this is not a probe(), so I don't see a point of using
dev_err_probe() here.
The function is only called from probe(), I think it makes sense to use
dev_err_probe() here.