On Wed, 29 Sept 2021 at 13:17, Andy Shevchenko <andriy.shevchenko@xxxxxxxxxxxxxxx> wrote: > > Refactor mmc_gpio_alloc() to drop unneeded indentation level > and double condition. This increases readability of the code. > > Signed-off-by: Andy Shevchenko <andriy.shevchenko@xxxxxxxxxxxxxxx> Applied for next, thanks! Kind regards Uffe > --- > drivers/mmc/core/slot-gpio.c | 34 +++++++++++++++++----------------- > 1 file changed, 17 insertions(+), 17 deletions(-) > > diff --git a/drivers/mmc/core/slot-gpio.c b/drivers/mmc/core/slot-gpio.c > index 05e907451df9..e365d328f43c 100644 > --- a/drivers/mmc/core/slot-gpio.c > +++ b/drivers/mmc/core/slot-gpio.c > @@ -39,24 +39,24 @@ static irqreturn_t mmc_gpio_cd_irqt(int irq, void *dev_id) > > int mmc_gpio_alloc(struct mmc_host *host) > { > - struct mmc_gpio *ctx = devm_kzalloc(host->parent, > - sizeof(*ctx), GFP_KERNEL); > - > - if (ctx) { > - ctx->cd_debounce_delay_ms = 200; > - ctx->cd_label = devm_kasprintf(host->parent, GFP_KERNEL, > - "%s cd", dev_name(host->parent)); > - if (!ctx->cd_label) > - return -ENOMEM; > - ctx->ro_label = devm_kasprintf(host->parent, GFP_KERNEL, > - "%s ro", dev_name(host->parent)); > - if (!ctx->ro_label) > - return -ENOMEM; > - host->slot.handler_priv = ctx; > - host->slot.cd_irq = -EINVAL; > - } > + const char *devname = dev_name(host->parent); > + struct mmc_gpio *ctx; > + > + ctx = devm_kzalloc(host->parent, sizeof(*ctx), GFP_KERNEL); > + if (!ctx) > + return -ENOMEM; > + > + ctx->cd_debounce_delay_ms = 200; > + ctx->cd_label = devm_kasprintf(host->parent, GFP_KERNEL, "%s cd", devname); > + if (!ctx->cd_label) > + return -ENOMEM; > + ctx->ro_label = devm_kasprintf(host->parent, GFP_KERNEL, "%s ro", devname); > + if (!ctx->ro_label) > + return -ENOMEM; > + host->slot.handler_priv = ctx; > + host->slot.cd_irq = -EINVAL; > > - return ctx ? 0 : -ENOMEM; > + return 0; > } > > int mmc_gpio_get_ro(struct mmc_host *host) > -- > 2.33.0 >