> -----Original Message----- > From: AKASHI Takahiro [mailto:takahiro.akashi@xxxxxxxxxx] > Sent: 2020年11月6日 10:27 > To: ulf.hansson@xxxxxxxxxx; adrian.hunter@xxxxxxxxx > Cc: linux-mmc@xxxxxxxxxxxxxxx; linux-kernel@xxxxxxxxxxxxxxx; > ben.chuang@xxxxxxxxxxxxxxxxxxx; greg.tu@xxxxxxxxxxxxxxxxxxx; AKASHI > Takahiro <takahiro.akashi@xxxxxxxxxx> > Subject: [RFC PATCH v3.1 03/27] mmc: core: UHS-II support, skip > set_chip_select() > > mmc_set_chip_select() should be called only in UHS-II mode, and not for UHS-II > mode. Typo, only in UHS-I mode. Regards Haibo Chen > > Signed-off-by: Ben Chuang <ben.chuang@xxxxxxxxxxxxxxxxxxx> > Signed-off-by: AKASHI Takahiro <takahiro.akashi@xxxxxxxxxx> > --- > drivers/mmc/core/core.c | 6 ++++-- > 1 file changed, 4 insertions(+), 2 deletions(-) > > diff --git a/drivers/mmc/core/core.c b/drivers/mmc/core/core.c index > 5541ed956c4d..4e12bd98fc08 100644 > --- a/drivers/mmc/core/core.c > +++ b/drivers/mmc/core/core.c > @@ -898,8 +898,10 @@ static inline void mmc_set_ios(struct mmc_host > *host) > */ > void mmc_set_chip_select(struct mmc_host *host, int mode) { > - host->ios.chip_select = mode; > - mmc_set_ios(host); > + if (!(host->flags & MMC_UHS2_INITIALIZED)) { > + host->ios.chip_select = mode; > + mmc_set_ios(host); > + } > } > > /* > -- > 2.28.0