On 08. 10. 20 4:09, muhammad.husaini.zulkifli@xxxxxxxxx wrote: > From: Muhammad Husaini Zulkifli <muhammad.husaini.zulkifli@xxxxxxxxx> > > Add struct device *dev in probe func() so that it can widely use in > probe to make code more readable. > > Signed-off-by: Muhammad Husaini Zulkifli <muhammad.husaini.zulkifli@xxxxxxxxx> > --- > drivers/mmc/host/sdhci-of-arasan.c | 1 + > 1 file changed, 1 insertion(+) > > diff --git a/drivers/mmc/host/sdhci-of-arasan.c b/drivers/mmc/host/sdhci-of-arasan.c > index f186fbd016b1..46aea6516133 100644 > --- a/drivers/mmc/host/sdhci-of-arasan.c > +++ b/drivers/mmc/host/sdhci-of-arasan.c > @@ -1521,6 +1521,7 @@ static int sdhci_arasan_probe(struct platform_device *pdev) > struct sdhci_pltfm_host *pltfm_host; > struct sdhci_arasan_data *sdhci_arasan; > struct device_node *np = pdev->dev.of_node; > + struct device *dev = &pdev->dev; > const struct sdhci_arasan_of_data *data; > > match = of_match_node(sdhci_arasan_of_match, pdev->dev.of_node); > This is not what we discussed. You create new variable and you should just use it in that function. s/pdev->dev\./dev->/g Thanks, Michal