On Mon, Nov 26, 2018 at 9:23 PM Robert Jarzmik <robert.jarzmik@xxxxxxx> wrote: > > + /* Card detect on GPIO 83 */ > > + GPIO_LOOKUP("gpio-pxa", 83, "cd", GPIO_ACTIVE_LOW), > > This 83 magic number escaped your third pass, that was the "Don't use number, > only defines." comment in the former iteration. Sorry :( I was just sloppy and forgetful. I fixed it. > > static void __init colibri_mmc_init(void) > > { > > if (machine_is_colibri()) /* PXA270 Colibri */ > > colibri_mci_platform_data.gpio_card_detect = > > GPIO0_COLIBRI_PXA270_SD_DETECT; > > + gpiod_add_lookup_table(&colibri_pxa270_mci_gpio_table); > > This looks weird. Either the indentation of the gpiod_add_lookup_table() is > wrong, or more probably the assignment above is to be removed in a next patch. It's a bug, sorry. > I wouldn't mind having the condition repeated to ease the next patch, ie: Nah I just rebased it and dealt with the conflicts, it's all I do all days anyways :D > > if (machine_is_em_x270()) > > em_x270_mci_platform_data.get_ro = em_x270_mci_get_ro; > > + gpiod_add_lookup_table(&em_x270_mci_wp_gpio_table); > > Same comment here. Fixed this too. Yours, Linus Walleij