I have collected some cleanups along the road on the mmc core, now I thought it was time to post them. None of these changes causes any functional changes, but the goal is rather to just make the code more readable and avoid open coding. Ulf Hansson (9): mmc: core: Don't export some eMMC specific functions from core.c mmc: core: Move mmc bkops functions from core.c to mmc_ops.c mmc: core: Move mmc_interrupt_hpi() from core.c to mmc_ops.c mmc: core: Move mmc_flush_cache() from core.c to mmc_ops.c mmc: core: Make mmc_can_reset() static mmc: core: Remove redundant code in mmc_send_cid() mmc: core: Re-factor code for sending CID mmc: core: Drop mmc_all_send_cid() and use mmc_send_cxd_native() instead mmc: core: Clarify code for sending CSD drivers/mmc/core/core.c | 207 ------------------------------------- drivers/mmc/core/mmc.c | 8 +- drivers/mmc/core/mmc_ops.c | 250 +++++++++++++++++++++++++++++++++++++++------ drivers/mmc/core/mmc_ops.h | 3 - drivers/mmc/core/sd.c | 6 +- 5 files changed, 221 insertions(+), 253 deletions(-) -- 2.7.4 -- To unsubscribe from this list: send the line "unsubscribe linux-mmc" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html