Re: [PATCH V2] mmc: block: Use __mmc_send_status() and drop get_card_status()

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Mon, May 22, 2017 at 10:23 AM, Ulf Hansson <ulf.hansson@xxxxxxxxxx> wrote:

> The only reason to why the mmc block device driver needs to implements its
> own version of how to get the status of the card, is that it needs to
> specify a different amount of retries.
>
> Therefore add a new exported function which allows the caller to specify
> the number of retries and convert everybody to use it, as this simplifies
> the code.
>
> Signed-off-by: Ulf Hansson <ulf.hansson@xxxxxxxxxx>
> ---
>
> Changes in v2:
>         - Allow callers to specify retries.

Im allergic to __prefixes so I would call this:

> -int mmc_send_status(struct mmc_card *card, u32 *status)
> +int __mmc_send_status(struct mmc_card *card, u32 *status, unsigned int retries)

mmc_send_status_command()

Either way, it's a clever patch so:
Reviewed-by: Linus Walleij <linus.walleij@xxxxxxxxxx>

Yours,
Linus Walleij
--
To unsubscribe from this list: send the line "unsubscribe linux-mmc" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html



[Index of Archives]     [Linux USB Devel]     [Linux Media]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux