Re: [PATCH] mmc: dw_mmc: Fix some coding style

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Wed, Jan 4, 2017 at 2:52 PM, Ziyuan Xu <xzy.xu@xxxxxxxxxxxxxx> wrote:
> Let's fix the warnings from checkpatch.pl:
>
> - line over 80 characters;
> - block comments should align the * on each Lines;
> - statements not starting on a tabstop.

>         __le32          des1;   /* Buffer sizes */
>  #define IDMAC_SET_BUFFER1_SIZE(d, s) \
> -       ((d)->des1 = ((d)->des1 & cpu_to_le32(0x03ffe000)) | (cpu_to_le32((s) & 0x1fff)))
> +       ((d)->des1 = ((d)->des1 & cpu_to_le32(0x03ffe000)) | \
> +        (cpu_to_le32((s) & 0x1fff)))

I don't think there is a significant value to split. How many
characters it fits right now?
Up to 90 for such a code is okay for my point of view. It makes it
more readable than split variant.

-- 
With Best Regards,
Andy Shevchenko
--
To unsubscribe from this list: send the line "unsubscribe linux-mmc" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html



[Index of Archives]     [Linux USB Devel]     [Linux Media]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux