On Mon, Dec 12, 2016 at 8:51 PM, Wolfram Sang <wsa+renesas@xxxxxxxxxxxxxxxxxxxx> wrote: > We need a SCC unit for hw_reset. Those units can only be described in > of_data. So, of_data and a valid SCC offset are prerequisites for > enabling the hw_reset capability. Merge the two 'if' conditions into one > and add a check for an scc offset. > > Signed-off-by: Wolfram Sang <wsa+renesas@xxxxxxxxxxxxxxxxxxxx> Reviewed-by: Geert Uytterhoeven <geert+renesas@xxxxxxxxx> > --- > drivers/mmc/host/sh_mobile_sdhi.c | 30 ++++++++++++++---------------- > 1 file changed, 14 insertions(+), 16 deletions(-) > > diff --git a/drivers/mmc/host/sh_mobile_sdhi.c b/drivers/mmc/host/sh_mobile_sdhi.c > index b48e3ae4549b6b..f3ea2c8b12040c 100644 > --- a/drivers/mmc/host/sh_mobile_sdhi.c > +++ b/drivers/mmc/host/sh_mobile_sdhi.c > @@ -656,27 +656,25 @@ static int sh_mobile_sdhi_probe(struct platform_device *pdev) > if (ret < 0) > goto efree; > > - if (host->mmc->caps & MMC_CAP_UHS_SDR104) { > + if (of_data && of_data->scc_offset && host->mmc->caps & MMC_CAP_UHS_SDR104) { For readability, you may want to add parentheses around the last check, and break the long line before the classical punch card line limit. Gr{oetje,eeting}s, Geert -- Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@xxxxxxxxxxxxxx In personal conversations with technical people, I call myself a hacker. But when I'm talking to journalists I just say "programmer" or something like that. -- Linus Torvalds -- To unsubscribe from this list: send the line "unsubscribe linux-mmc" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html