Re: [PATCH] mmc: pwrseq: use gpiod_get() instead of index 0

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 14 September 2015 at 14:00, Javier Martinez Canillas
<javier@xxxxxxxxxxxxxxx> wrote:
> The gpiod_get() function expands to gpiod_get_index() with index 0
> so it's better to use it since is easier to read and more concise.
>
> Signed-off-by: Javier Martinez Canillas <javier@xxxxxxxxxxxxxxx>

Thanks, applied for next!

Kind regards
Uffe

>
> ---
>
>  drivers/mmc/core/pwrseq_emmc.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/mmc/core/pwrseq_emmc.c b/drivers/mmc/core/pwrseq_emmc.c
> index 9d6d2fb21796..137c97fb7aa8 100644
> --- a/drivers/mmc/core/pwrseq_emmc.c
> +++ b/drivers/mmc/core/pwrseq_emmc.c
> @@ -76,7 +76,7 @@ struct mmc_pwrseq *mmc_pwrseq_emmc_alloc(struct mmc_host *host,
>         if (!pwrseq)
>                 return ERR_PTR(-ENOMEM);
>
> -       pwrseq->reset_gpio = gpiod_get_index(dev, "reset", 0, GPIOD_OUT_LOW);
> +       pwrseq->reset_gpio = gpiod_get(dev, "reset", GPIOD_OUT_LOW);
>         if (IS_ERR(pwrseq->reset_gpio)) {
>                 ret = PTR_ERR(pwrseq->reset_gpio);
>                 goto free;
> --
> 2.4.3
>
--
To unsubscribe from this list: send the line "unsubscribe linux-mmc" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html



[Index of Archives]     [Linux USB Devel]     [Linux Media]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux