* Arnd Bergmann <arnd@xxxxxxxx> [150515 14:26]: > On Friday 15 May 2015 23:22:37 Pali Rohár wrote: > > On Friday 15 May 2015 23:19:44 Arnd Bergmann wrote: > > > On Friday 15 May 2015 23:14:48 Pali Rohár wrote: > > > > diff --git a/drivers/mmc/host/omap_hsmmc.c > > > > b/drivers/mmc/host/omap_hsmmc.c index 9df2b68..f6073dd 100644 > > > > --- a/drivers/mmc/host/omap_hsmmc.c > > > > +++ b/drivers/mmc/host/omap_hsmmc.c > > > > @@ -1901,6 +1901,8 @@ static struct omap_hsmmc_platform_data > > > > *of_get_hsmmc_pdata(struct device *dev) > > > > > > > > if (of_find_property(np, "ti,needs-special-hs-handling", > > > > NULL)) > > > > > > > > pdata->features |= HSMMC_HAS_HSPE_SUPPORT; > > > > > > > > + of_property_read_string(np, "slot-name", &pdata->name); > > > > + > > > > > > > > return pdata; > > > > > > > > } > > > > > > This property needs to be documented in > > > Documentation/devicetree/bindings/mmc/mmc.txt and preferably the > > > implementation moved into mmc_of_parse. > > > > > > We should not have an interface like this specific to one driver. > > > > > > Arnd > > > > Interface is already present for platform data code (which do not use > > DT). So "pdata->name" is not DT specific... > > > > The driver can of course keep providing the name from platform_data where > that is used. All I was saying is that when you introduce a DT property, > it should not be specific to that driver. Yes sounds like it would be a usable generic binding. Not sure that it should be called slot-name though, maybe you can use the MMC driver instance name instead? I don't think much any drivers support multiple MMC slots although it's in the original MMC spec. If setting up the generic binding is expected to take a while, you can naturally pass it in pdata while waiting for the generic binding to get merged. Regards, Tony -- To unsubscribe from this list: send the line "unsubscribe linux-mmc" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html