On Tuesday 23 September 2014 15:55:08 behanw@xxxxxxxxxxxxxxxxxx wrote: > --- a/drivers/mmc/host/sdhci-bcm-kona.c > +++ b/drivers/mmc/host/sdhci-bcm-kona.c > @@ -225,7 +225,7 @@ static struct sdhci_pltfm_data sdhci_pltfm_data_kona = { > SDHCI_QUIRK_CAP_CLOCK_BASE_BROKEN, > }; > > -static struct __initconst of_device_id sdhci_bcm_kona_of_match[] = { > +static struct of_device_id const sdhci_bcm_kona_of_match[] = { > { .compatible = "brcm,kona-sdhci"}, > { .compatible = "bcm,kona-sdhci"}, /* deprecated name */ > {} > Sorry for giving you trouble over such a simple patch (especially one that I have acked already), but I just noticed that this is not following the common style we use in the kernel. Almost everywhere in Linux, we use static const struct of_device_id sdhci_bcm_kona_of_match[] = { not static struct of_device_id const sdhci_bcm_kona_of_match[] = { AFAICT they behave in identical ways, but the first one seems easier to read for someone familiar with kernel code. Arnd -- To unsubscribe from this list: send the line "unsubscribe linux-mmc" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html