[PATCH 1/4] mmc: rename ddr to uhs in ios structure to indicate usage

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



uhs mode comprises dual data rate, single data rate options
such as ddr_1_8v as well as sdr50 and sdr104
ddr name changed to indicate its true usage

Signed-off-by: Philip Rakity <prakity@xxxxxxxxxxx>
---
 drivers/mmc/core/core.c  |    2 +-
 include/linux/mmc/host.h |    2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/mmc/core/core.c b/drivers/mmc/core/core.c
index d9fb0d3..37e66d3 100644
--- a/drivers/mmc/core/core.c
+++ b/drivers/mmc/core/core.c
@@ -718,7 +718,7 @@ void mmc_set_bus_width_ddr(struct mmc_host *host, unsigned int width,
 			   unsigned int ddr)
 {
 	host->ios.bus_width = width;
-	host->ios.ddr = ddr;
+	host->ios.uhs = ddr;
 	mmc_set_ios(host);
 }
 
diff --git a/include/linux/mmc/host.h b/include/linux/mmc/host.h
index bcb793e..f11307e 100644
--- a/include/linux/mmc/host.h
+++ b/include/linux/mmc/host.h
@@ -51,7 +51,7 @@ struct mmc_ios {
 #define MMC_TIMING_MMC_HS	1
 #define MMC_TIMING_SD_HS	2
 
-	unsigned char	ddr;			/* dual data rate used */
+	unsigned char	uhs;			/* uhs mode used (ddr - sdr) */
 
 #define MMC_SDR_MODE		0
 #define MMC_1_2V_DDR_MODE	1
-- 
1.7.0.4


--
To unsubscribe from this list: send the line "unsubscribe linux-mmc" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[Index of Archives]     [Linux USB Devel]     [Linux Media]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux