>> + >> + for (f = mmc_fixup_methods; f->hook; f++) { >> + if ((f->vendor == card->cis.vendor >> + || f->vendor == (u16) SDIO_ANY_ID) && >> + (f->device == card->cis.device >> + || f->device == (u16) SDIO_ANY_ID)) { >> + dev_dbg(&card->dev, "calling %pF\n", f->hook); >> + f->hook(card, f->data); > > > hook is not a very nice name --- something more meaningful: vendor_fixup ? I just copied the pci/quirks.c way of doing. I think is more coherent to keep is this way, this name will forever appear only in 4 lines inside the kernel, so I dont care that much. I'll change that if you really do care. :-) Waiting for a few more comments to do all in a row. Thanks, -- Pierre -- To unsubscribe from this list: send the line "unsubscribe linux-mmc" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html