Re: [PATCH RESEND] sdhci-clk-gating-support

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi Madhav,

+       host->user = 0;         /*For Clock gating*/
+       host->clk_restore = 0;
Also, it's not obvious to me why two variables are necessary.  What's
wrong with just setting host->clk_restore when disabling clock, and
testing whether it's non-zero instead of testing host->user?
(host->user would need a more descriptive name, too.)
we used host->user for making enable disable in a proper sequence i.e. enable-disable-enable and were facing some issues as we were using workqueue.So in current version we tested the patch
without host->user and it works fine so we can remove it.
Some general points:
* have you measured whether there's a performance impact from
  bringing the clock up and down for every request?
I will test  this and update you soon.
* I'd expect this to be implemented as an MMC capability, so
  that it can be avoided on specific controllers.
Yes we can do this just we need to add one macro for clock gating capability in struct mmc_host and also looking for any other good alternative for the same. Do we have such host controllers for them we
should avoid this??


Thanks,

- Chris.
--
Chris Ball   <cjb@xxxxxxxxxx>
One Laptop Per Child

--
To unsubscribe from this list: send the line "unsubscribe linux-mmc" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[Index of Archives]     [Linux USB Devel]     [Linux Media]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux