On Wed 18-11-15 21:31:32, Geliang Tang wrote: > Use PFN_DOWN() in should_add_memory_movable() to keep the consistency > of this file. I really detest this patch and c8e861a531b0 ("mm/memory_hotplug.c: use PFN_DOWN()") which has started to use PFN_DOWN in that file likewise. It obfuscates a perfectly understandable construct of addr->pfn conversion by a macro which I have to really check what it does because the name suggests I am rounding an existing pfn down. This really doesn't help the readability. > > Signed-off-by: Geliang Tang <geliangtang@xxxxxxx> > --- > mm/memory_hotplug.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/mm/memory_hotplug.c b/mm/memory_hotplug.c > index 67d488a..7c44ff7 100644 > --- a/mm/memory_hotplug.c > +++ b/mm/memory_hotplug.c > @@ -1205,7 +1205,7 @@ static int check_hotplug_memory_range(u64 start, u64 size) > */ > static int should_add_memory_movable(int nid, u64 start, u64 size) > { > - unsigned long start_pfn = start >> PAGE_SHIFT; > + unsigned long start_pfn = PFN_DOWN(start); > pg_data_t *pgdat = NODE_DATA(nid); > struct zone *movable_zone = pgdat->node_zones + ZONE_MOVABLE; > > -- > 2.5.0 > > > -- > To unsubscribe, send a message with 'unsubscribe linux-mm' in > the body to majordomo@xxxxxxxxx. For more info on Linux MM, > see: http://www.linux-mm.org/ . > Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a> -- Michal Hocko SUSE Labs -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>