Re: [PATCH 3/7] mm/memblock: memblock_is_memory/reserved can be boolean

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Mon 16-11-15 14:51:22, Yaowei Bai wrote:
> This patch makes memblock_is_memory/reserved return bool to improve
> readability due to this particular function only using either
> one or zero as its return value.
> 
> No functional change.
> 
> Signed-off-by: Yaowei Bai <baiyaowei@xxxxxxxxxxxxxxxxxxxx>

Acked-by: Michal Hocko <mhocko@xxxxxxxx>

> ---
>  include/linux/memblock.h | 4 ++--
>  mm/memblock.c            | 4 ++--
>  2 files changed, 4 insertions(+), 4 deletions(-)
> 
> diff --git a/include/linux/memblock.h b/include/linux/memblock.h
> index 24daf8f..a25cce94 100644
> --- a/include/linux/memblock.h
> +++ b/include/linux/memblock.h
> @@ -318,9 +318,9 @@ phys_addr_t memblock_mem_size(unsigned long limit_pfn);
>  phys_addr_t memblock_start_of_DRAM(void);
>  phys_addr_t memblock_end_of_DRAM(void);
>  void memblock_enforce_memory_limit(phys_addr_t memory_limit);
> -int memblock_is_memory(phys_addr_t addr);
> +bool memblock_is_memory(phys_addr_t addr);
>  int memblock_is_region_memory(phys_addr_t base, phys_addr_t size);
> -int memblock_is_reserved(phys_addr_t addr);
> +bool memblock_is_reserved(phys_addr_t addr);
>  bool memblock_is_region_reserved(phys_addr_t base, phys_addr_t size);
>  
>  extern void __memblock_dump_all(void);
> diff --git a/mm/memblock.c b/mm/memblock.c
> index d300f13..1ab7b9e 100644
> --- a/mm/memblock.c
> +++ b/mm/memblock.c
> @@ -1509,12 +1509,12 @@ static int __init_memblock memblock_search(struct memblock_type *type, phys_addr
>  	return -1;
>  }
>  
> -int __init memblock_is_reserved(phys_addr_t addr)
> +bool __init memblock_is_reserved(phys_addr_t addr)
>  {
>  	return memblock_search(&memblock.reserved, addr) != -1;
>  }
>  
> -int __init_memblock memblock_is_memory(phys_addr_t addr)
> +bool __init_memblock memblock_is_memory(phys_addr_t addr)
>  {
>  	return memblock_search(&memblock.memory, addr) != -1;
>  }
> -- 
> 1.9.1
> 
> 

-- 
Michal Hocko
SUSE Labs

--
To unsubscribe, send a message with 'unsubscribe linux-mm' in
the body to majordomo@xxxxxxxxx.  For more info on Linux MM,
see: http://www.linux-mm.org/ .
Don't email: <a href=mailto:"dont@xxxxxxxxx";> email@xxxxxxxxx </a>



[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Bugtraq]     [Linux]     [Linux OMAP]     [Linux MIPS]     [ECOS]     [Asterisk Internet PBX]     [Linux API]