Hi David, On Tue, Oct 20, 2015 at 04:52:59PM +0100, David Woodhouse wrote: > void flush_tlb_kernel_range(unsigned long start, unsigned long end) > { > + intel_iommu_flush_kernel_pasid(start, end); A more generic naming would be good, and probably expose it through a function in the IOMMU-API. > +void intel_iommu_flush_kernel_pasid(unsigned long start, unsigned long end) > +{ > + struct dmar_drhd_unit *drhd; > + struct intel_iommu *iommu; > + unsigned long pages; And I think, as a performance optimiztion, we should bail out early here if the pasid has no users. Joerg -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>