On 10/01/2015 04:54 AM, Thomas Gleixner wrote: > On Mon, 28 Sep 2015, Dave Hansen wrote: >> > >> > /* >> > @@ -916,7 +918,10 @@ static int spurious_fault_check(unsigned >> > >> > if ((error_code & PF_INSTR) && !pte_exec(*pte)) >> > return 0; >> > - >> > + /* >> > + * Note: We do not do lazy flushing on protection key >> > + * changes, so no spurious fault will ever set PF_PK. >> > + */ > It might be a bit more clear to have: > > /* Comment .... */ > if ((error_code & PF_PK)) > return 1; > > return 1; > > That way the comment is associated to obviously redundant code, but > it's easier to read, especially if we add some new PF_ thingy after > that. Agreed, that's a nicer way to do it. I'll fix it up. -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>