On Mon, Sep 21, 2015 at 11:52:37AM +0100, Mel Gorman wrote: > @@ -119,10 +134,10 @@ struct vm_area_struct; > #define GFP_USER (__GFP_WAIT | __GFP_IO | __GFP_FS | __GFP_HARDWALL) > #define GFP_HIGHUSER (GFP_USER | __GFP_HIGHMEM) > #define GFP_HIGHUSER_MOVABLE (GFP_HIGHUSER | __GFP_MOVABLE) > -#define GFP_IOFS (__GFP_IO | __GFP_FS) > -#define GFP_TRANSHUGE (GFP_HIGHUSER_MOVABLE | __GFP_COMP | \ > - __GFP_NOMEMALLOC | __GFP_NORETRY | __GFP_NOWARN | \ > - __GFP_NO_KSWAPD) > +#define GFP_IOFS (__GFP_IO | __GFP_FS | __GFP_KSWAPD_RECLAIM) These are some really odd semantics to be given a name like that. GFP_IOFS was introduced as a short-hand for testing/setting/clearing these two bits at the same time, not to be used for allocations. In fact, the only user for allocations is lustre, and it's not at all obious why those sites shouldn't include __GFP_WAIT as well. Removing this definition altogether would probably be best. -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>