On Fri, 11 Sep 2015 10:02:29 +0800 Xishi Qiu <qiuxishi@xxxxxxxxxx> wrote: > Use IS_ALIGNED() to determine whether the shadow span two bytes. > It generates less code and more readable. > Please cc Andrey Ryabinin on kasan patches. > --- a/mm/kasan/kasan.c > +++ b/mm/kasan/kasan.c > @@ -120,7 +120,7 @@ static __always_inline bool memory_is_poisoned_8(unsigned long addr) > if (memory_is_poisoned_1(addr + 7)) > return true; > > - if (likely(((addr + 7) & KASAN_SHADOW_MASK) >= 7)) > + if (likely(IS_ALIGNED(addr, 8))) > return false; Wouldn't IS_ALIGNED(addr, KASAN_SHADOW_SCALE_SIZE) be more appropriate? But I'm not really sure what the original code is trying to do. if ((addr + 7) & 7) >= 7) can only evaluate true if ((addr + 7) & 7) equals 7, so the ">=" could be "==". I think. The code looks a bit weird. A code comment would help. And how come memory_is_poisoned_16() does IS_ALIGNED(addr, 8)? Should it be 16? -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>