On 2015-07-02 03:23 AM, Michal Hocko wrote: > On Wed 01-07-15 13:45:15, Nicholas Krause wrote: >> This makes the function set_recommended_min_free_kbytes have a >> return type of void now due to this particular function never >> needing to signal it's call if it fails due to this function >> always completing successfully without issue. > > The changelog is hard to read for me. > " > The function cannot possibly fail so it doesn't make much sense to have > a return value. Make it void. > " > Would sound much easier to parse for me. > > I doubt this would help the compiler to generate a better code but in > general it is better to have void return type when there is no failure > possible - which is the case here. > >> Signed-off-by: Nicholas Krause <xerofoify@xxxxxxxxx> > > Acked-by: Michal Hocko <mhocko@xxxxxxx> > >> --- >> mm/huge_memory.c | 3 +-- >> 1 file changed, 1 insertion(+), 2 deletions(-) >> >> diff --git a/mm/huge_memory.c b/mm/huge_memory.c >> index c107094..914a72a 100644 >> --- a/mm/huge_memory.c >> +++ b/mm/huge_memory.c >> @@ -104,7 +104,7 @@ static struct khugepaged_scan khugepaged_scan = { >> }; >> >> >> -static int set_recommended_min_free_kbytes(void) >> +static void set_recommended_min_free_kbytes(void) >> { >> struct zone *zone; >> int nr_zones = 0; >> @@ -139,7 +139,6 @@ static int set_recommended_min_free_kbytes(void) >> min_free_kbytes = recommended_min; >> } >> setup_per_zone_wmarks(); >> - return 0; >> } >> >> static int start_stop_khugepaged(void) >> -- >> 2.1.4 >> > That was exactly my point with these patches readability not compiler improvements. Otherwise I would have stated that in my commit messages and would argue readability improvements are important too for the kernel. Nick -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>