On Tue, Jun 30, 2015 at 04:35:45PM -0700, David Rientjes wrote: > I do understand the problem with the current VM_BUG_ON_PAGE() and > VM_BUG_ON_VMA() stuff, and it compels me to ask about just going back to > the normal > > VM_BUG_ON(cond); > > coupled with dump_page(), dump_vma(), dump_whatever(). It all seems so > much simpler to me. Is there a sensible way to couple them? I don't see much, except opencode VM_BUG_ON(): if (IS_ENABLED(CONFIG_DEBUG_VM) && cond) { dump_page(...); dump_vma(...); dump_whatever(); BUG(); } That's too verbose to me to be usable. BTW, I also tried[1] to solve this problem too, but people doesn't like either. [1] http://lkml.kernel.org/g/1412163121-4295-1-git-send-email-kirill.shutemov@xxxxxxxxxxxxxxx -- Kirill A. Shutemov -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>