Re: [PATCH 07/25] mm, vmscan: Make kswapd think of reclaim in terms of nodes

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Fri, Jun 12, 2015 at 03:05:00PM +0800, Hillf Danton wrote:
> > -	/* Reclaim above the high watermark. */
> > -	sc->nr_to_reclaim = max(SWAP_CLUSTER_MAX, high_wmark_pages(zone));
> > +	/* Aim to reclaim above all the zone high watermarks */
> > +	for (z = 0; z <= end_zone; z++) {
> > +		zone = pgdat->node_zones + end_zone;
> s/end_zone/z/ ?

Ouch, thanks!

With this bug, kswapd would reclaim based on a multiple of the highest
zone. Whether that was under or over reclaim would depend on the size of
that zone relative to lower zones.

> > +		nr_to_reclaim += high_wmark_pages(zone);
> > 
> [...]
> > @@ -3280,13 +3177,26 @@ static unsigned long balance_pgdat(pg_data_t *pgdat, int order,
> >  			compact_pgdat(pgdat, order);
> > 
> >  		/*
> > +		 * Stop reclaiming if any eligible zone is balanced and clear
> > +		 * node writeback or congested.
> > +		 */
> > +		for (i = 0; i <= *classzone_idx; i++) {
> > +			zone = pgdat->node_zones + i;
> > +
> > +			if (zone_balanced(zone, sc.order, 0, *classzone_idx)) {
> > +				clear_bit(PGDAT_CONGESTED, &pgdat->flags);
> > +				clear_bit(PGDAT_DIRTY, &pgdat->flags);
> > +				break;
> s/break/goto out/ ?

Yes. It'd actually be ok because it'll detect the same condition and
exit in the next outer loop but goto out is better.


-- 
Mel Gorman
SUSE Labs

--
To unsubscribe, send a message with 'unsubscribe linux-mm' in
the body to majordomo@xxxxxxxxx.  For more info on Linux MM,
see: http://www.linux-mm.org/ .
Don't email: <a href=mailto:"dont@xxxxxxxxx";> email@xxxxxxxxx </a>



[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Bugtraq]     [Linux]     [Linux OMAP]     [Linux MIPS]     [ECOS]     [Asterisk Internet PBX]     [Linux API]