[PATCHv2 0/4] Cleanup mm_populate() codepath

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



While reading mlock()- and mm_populate()-related code, I've found several
things confusing. This patchset cleanup the codepath for future readers.

v2:
 - Fix typos pointed by David Rientjes;
 - Apply acks;

Kirill A. Shutemov (4):
  mm: rename FOLL_MLOCK to FOLL_POPULATE
  mm: rename __mlock_vma_pages_range() to populate_vma_page_range()
  mm: move gup() -> posix mlock() error conversion out of __mm_populate
  mm: move mm_populate()-related code to mm/gup.c

 Documentation/vm/unevictable-lru.txt |  26 +++----
 include/linux/mm.h                   |   2 +-
 mm/gup.c                             | 124 ++++++++++++++++++++++++++++++++-
 mm/huge_memory.c                     |   2 +-
 mm/internal.h                        |   2 +-
 mm/mlock.c                           | 131 +++--------------------------------
 mm/mmap.c                            |   4 +-
 7 files changed, 142 insertions(+), 149 deletions(-)

-- 
2.1.4

--
To unsubscribe, send a message with 'unsubscribe linux-mm' in
the body to majordomo@xxxxxxxxx.  For more info on Linux MM,
see: http://www.linux-mm.org/ .
Don't email: <a href=mailto:"dont@xxxxxxxxx";> email@xxxxxxxxx </a>




[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Bugtraq]     [Linux]     [Linux OMAP]     [Linux MIPS]     [ECOS]     [Asterisk Internet PBX]     [Linux API]