On (01/28/15 17:15), Minchan Kim wrote: > Admin could reset zram during I/O operation going on so we have > used zram->init_lock as read-side lock in I/O path to prevent > sudden zram meta freeing. > > However, the init_lock is really troublesome. > We can't do call zram_meta_alloc under init_lock due to lockdep splat > because zram_rw_page is one of the function under reclaim path and > hold it as read_lock while other places in process context hold it > as write_lock. So, we have used allocation out of the lock to avoid > lockdep warn but it's not good for readability and fainally, I met > another lockdep splat between init_lock and cpu_hotpulug from > kmem_cache_destroy during wokring zsmalloc compaction. :( > > Yes, the ideal is to remove horrible init_lock of zram in rw path. > This patch removes it in rw path and instead, put init_done bool > variable to check initialization done with smp_[wmb|rmb] and > srcu_[un]read_lock to prevent sudden zram meta freeing > during I/O operation. > > Signed-off-by: Minchan Kim <minchan@xxxxxxxxxx> > --- > drivers/block/zram/zram_drv.c | 85 +++++++++++++++++++++++++++++++------------ > drivers/block/zram/zram_drv.h | 5 +++ > 2 files changed, 66 insertions(+), 24 deletions(-) > > diff --git a/drivers/block/zram/zram_drv.c b/drivers/block/zram/zram_drv.c > index a598ada817f0..b33add453027 100644 > --- a/drivers/block/zram/zram_drv.c > +++ b/drivers/block/zram/zram_drv.c > @@ -32,6 +32,7 @@ > #include <linux/string.h> > #include <linux/vmalloc.h> > #include <linux/err.h> > +#include <linux/srcu.h> > > #include "zram_drv.h" > > @@ -53,9 +54,31 @@ static ssize_t name##_show(struct device *d, \ > } \ > static DEVICE_ATTR_RO(name); > > -static inline int init_done(struct zram *zram) > +static inline bool init_done(struct zram *zram) > { > - return zram->meta != NULL; > + /* > + * init_done can be used without holding zram->init_lock in > + * read/write handler(ie, zram_make_request) but we should make sure > + * that zram->init_done should set up after meta initialization is > + * done. Look at setup_init_done. > + */ > + bool ret = zram->init_done; I don't like re-introduced ->init_done. another idea... how about using `zram->disksize == 0' instead of `->init_done' (previously `->meta != NULL')? should do the trick. and I'm not sure I get this rmb... -ss -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>