Vlastimil Babka <vbabka@xxxxxxx> writes: > On 01/21/2015 01:48 AM, Andrew Morton wrote: >> On Tue, 20 Jan 2015 17:04:31 +0530 "Aneesh Kumar K.V" <aneesh.kumar@xxxxxxxxxxxxxxxxxx> wrote: >>> + * Should be called with the mm_sem of the vma hold. >> >> That's a pretty cruddy sentence, isn't it? Copied from >> alloc_pages_vma(). "vma->vm_mm->mmap_sem" would be better. >> >> And it should tell us whether mmap_sem required a down_read or a >> down_write. What purpose is it serving? > > This is already said for mmap_sem further above this comment line, which > should be just deleted (and from alloc_hugepage_vma comment too). > >>> + * >>> + */ >>> +struct page *alloc_hugepage_vma(gfp_t gfp, struct vm_area_struct *vma, >>> + unsigned long addr, int order) >> >> This pointlessly bloats the kernel if CONFIG_TRANSPARENT_HUGEPAGE=n? >> >> >> >> --- a/mm/mempolicy.c~mm-thp-allocate-transparent-hugepages-on-local-node-fix >> +++ a/mm/mempolicy.c > > How about this cleanup on top? I'm not fully decided on the GFP_TRANSHUGE test. > This is potentially false positive, although I doubt anything else uses the same > gfp mask bits. IMHO I found that to be more complex. > > Should "hugepage" be extra bool parameter instead? Should I #ifdef the parameter > only for CONFIG_TRANSPARENT_HUGEPAGE, or is it not worth the ugliness? > I guess if we really want to consolidate both the functions, we should try the above, without all those #ifdef. It is just one extra arg. But then is the reason to consolidate that strong ? -aneesh -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>