On Wed 07-01-15 10:36:58, Vlastimil Babka wrote: > On 01/06/2015 10:44 PM, Michal Hocko wrote: > > On Tue 06-01-15 22:10:55, Vlastimil Babka wrote: > >> On 01/06/2015 03:30 PM, Michal Hocko wrote: > > [...] > >> > diff --git a/mm/page_alloc.c b/mm/page_alloc.c > >> > index 1bb65e6f48dd..1682d766cb8e 100644 > >> > --- a/mm/page_alloc.c > >> > +++ b/mm/page_alloc.c > >> > @@ -2175,10 +2175,11 @@ zonelist_scan: > >> > } > >> > > >> > try_this_zone: > >> > - page = buffered_rmqueue(preferred_zone, zone, order, > >> > + do { > >> > + page = buffered_rmqueue(preferred_zone, zone, order, > >> > gfp_mask, migratetype); > >> > - if (page) > >> > - break; > >> > + } while (page && prep_new_page(page, order, gfp_mask, > >> > + alloc_flags)); > >> > >> Hm but here we wouldn't return page on success. > > > > Right. > > > >> I wonder if you overlooked the return, hence your "not breaking out of > >> the loop" remark? > > > > This was merely to show the intention. Sorry for not being clear enough. > > OK, but I don't see other way than to follow this do-while with another > > if (page) > return page; > > So I think it would be more complicated than now. We wouldn't even be able to > remove the 'try_this_zone' label, since it's used for goto from elsewhere as well. Getting rid of the label wasn't the intention. I just found the allocation retry easier to follow this way. I have no objection if you keep the code as is. > Now that I'm thinking of it, maybe we should have a "goto zonelist_scan" there > instead. We discard a bad page and might come below the watermarks. But the > chances of this mattering are tiny I guess. If anything this would be worth a separate patch. -- Michal Hocko SUSE Labs -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>