On Wed, Nov 12, 2014 at 05:33:12PM -0500, Luiz Capitulino wrote: > No reason to duplicate the code of an existing macro. > > Signed-off-by: Luiz Capitulino <lcapitulino@xxxxxxxxxx> I think that we can apply the same macro for the following two lines in __unmap_hugepage_range(): BUG_ON(start & ~huge_page_mask(h)); BUG_ON(end & ~huge_page_mask(h)); Anyway, this makes the code more readable. Acked-by: Naoya Horiguchi <n-horiguchi@xxxxxxxxxxxxx> > --- > mm/hugetlb.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/mm/hugetlb.c b/mm/hugetlb.c > index 9fd7227..a10fd57 100644 > --- a/mm/hugetlb.c > +++ b/mm/hugetlb.c > @@ -1457,7 +1457,7 @@ int __weak alloc_bootmem_huge_page(struct hstate *h) > return 0; > > found: > - BUG_ON((unsigned long)virt_to_phys(m) & (huge_page_size(h) - 1)); > + BUG_ON(!IS_ALIGNED(virt_to_phys(m), huge_page_size(h))); > /* Put them into a private list first because mem_map is not up yet */ > list_add(&m->list, &huge_boot_pages); > m->hstate = h; > -- > 1.9.3 > > -- > To unsubscribe, send a message with 'unsubscribe linux-mm' in > the body to majordomo@xxxxxxxxx. For more info on Linux MM, > see: http://www.linux-mm.org/ . > Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a> -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href