Re: [fuse-devel] [PATCH v5 7/7] add a flag for per-operation O_DSYNC semantics

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 





On Thu, Nov 6, 2014 at 8:22 PM, Anton Altaparmakov <aia21@xxxxxxxxx> wrote:
> On 7 Nov 2014, at 01:46, Jeff Moyer <jmoyer@xxxxxxxxxx> wrote:
> Minor nit, but I'd rather read something that looks like this:
>
>       if (type == READ && (flags & RWF_NONBLOCK))
>               return -EAGAIN;
>       else if (type == WRITE && (flags & RWF_DSYNC))
>               return -EINVAL;

But your version is less logically efficient for the case where "type == READ" is true and "flags & RWF_NONBLOCK" is false because your version then has to do the "if (type == WRITE" check before discovering it does not need to take that branch either, whilst the original version does not have to do such a test at all.

Seriously? Just focus on the code readability/maintainability which makes the code most easily understood/obvious to a new pair of eyes, and leave such micro-optimizations to the compiler..

Thanks

[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Bugtraq]     [Linux]     [Linux OMAP]     [Linux MIPS]     [ECOS]     [Asterisk Internet PBX]     [Linux API]