Re: [PATCH v2] memory-hotplug: add sysfs zones_online_to attribute

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



(2014/08/18 12:25), Zhang Zhen wrote:
On 2014/8/16 5:37, Toshi Kani wrote:
On Wed, 2014-08-13 at 12:10 +0800, Zhang Zhen wrote:
Currently memory-hotplug has two limits:
1. If the memory block is in ZONE_NORMAL, you can change it to
ZONE_MOVABLE, but this memory block must be adjacent to ZONE_MOVABLE.
2. If the memory block is in ZONE_MOVABLE, you can change it to
ZONE_NORMAL, but this memory block must be adjacent to ZONE_NORMAL.

With this patch, we can easy to know a memory block can be onlined to
which zone, and don't need to know the above two limits.

Updated the related Documentation.

Change v1 -> v2:
- optimize the implementation following Dave Hansen's suggestion

Signed-off-by: Zhang Zhen <zhenzhang.zhang@xxxxxxxxxx>
---
  Documentation/ABI/testing/sysfs-devices-memory |  8 ++++
  Documentation/memory-hotplug.txt               |  4 +-
  drivers/base/memory.c                          | 62 ++++++++++++++++++++++++++
  include/linux/memory_hotplug.h                 |  1 +
  mm/memory_hotplug.c                            |  2 +-
  5 files changed, 75 insertions(+), 2 deletions(-)

diff --git a/Documentation/ABI/testing/sysfs-devices-memory b/Documentation/ABI/testing/sysfs-devices-memory
index 7405de2..2b2a1d7 100644
--- a/Documentation/ABI/testing/sysfs-devices-memory
+++ b/Documentation/ABI/testing/sysfs-devices-memory
@@ -61,6 +61,14 @@ Users:		hotplug memory remove tools
  		http://www.ibm.com/developerworks/wikis/display/LinuxP/powerpc-utils



+What:           /sys/devices/system/memory/memoryX/zones_online_to

I think this name is a bit confusing.  How about "valid_online_types"?

Thanks for your suggestion.

This patch has been added to -mm tree.
If most people think so, i would like to modify the interface name.

I like Toshi's idea (valid_online_types).

Thanks,
Yasuaki Ishimatsu

If not, let's leave it as it is.

Best regards!
Thanks,
-Toshi



--
To unsubscribe, send a message with 'unsubscribe linux-mm' in
the body to majordomo@xxxxxxxxx.  For more info on Linux MM,
see: http://www.linux-mm.org/ .
Don't email: <a href=mailto:"dont@xxxxxxxxx";> email@xxxxxxxxx </a>






--
To unsubscribe, send a message with 'unsubscribe linux-mm' in
the body to majordomo@xxxxxxxxx.  For more info on Linux MM,
see: http://www.linux-mm.org/ .
Don't email: <a href=mailto:"dont@xxxxxxxxx";> email@xxxxxxxxx </a>




[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Bugtraq]     [Linux]     [Linux OMAP]     [Linux MIPS]     [ECOS]     [Asterisk Internet PBX]     [Linux API]