Re: slub/debugobjects: lockup when freeing memory

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Thu, 19 Jun 2014, Paul E. McKenney wrote:
> On Thu, Jun 19, 2014 at 11:32:41PM +0200, Thomas Gleixner wrote:
> > 
> > 
> > On Thu, 19 Jun 2014, Paul E. McKenney wrote:
> > 
> > > On Thu, Jun 19, 2014 at 10:37:17PM +0200, Thomas Gleixner wrote:
> > > > On Thu, 19 Jun 2014, Paul E. McKenney wrote:
> > > > > On Thu, Jun 19, 2014 at 09:29:08PM +0200, Thomas Gleixner wrote:
> > > > > > On Thu, 19 Jun 2014, Paul E. McKenney wrote:
> > > > > > Well, no. Look at the callchain:
> > > > > > 
> > > > > > __call_rcu
> > > > > >     debug_object_activate
> > > > > >        rcuhead_fixup_activate
> > > > > >           debug_object_init
> > > > > >               kmem_cache_alloc
> > > > > > 
> > > > > > So call rcu activates the object, but the object has no reference in
> > > > > > the debug objects code so the fixup code is called which inits the
> > > > > > object and allocates a reference ....
> > > > > 
> > > > > OK, got it.  And you are right, call_rcu() has done this for a very
> > > > > long time, so not sure what changed.  But it seems like the right
> > > > > approach is to provide a debug-object-free call_rcu_alloc() for use
> > > > > by the memory allocators.
> > > > > 
> > > > > Seem reasonable?  If so, please see the following patch.
> > > > 
> > > > Not really, you're torpedoing the whole purpose of debugobjects :)
> > > > 
> > > > So, why can't we just init the rcu head when the stuff is created?
> > > 
> > > That would allow me to keep my code unchanged, so I am in favor.  ;-)
> > 
> > Almost unchanged. You need to provide a function to do so, i.e. make
> > use of
> > 
> >     debug_init_rcu_head()
> 
> You mean like this?

I'd rather name it init_rcu_head() and free_rcu_head() w/o the debug_
prefix, so it's consistent with init_rcu_head_on_stack /
destroy_rcu_head_on_stack. But either way works for me.

Acked-by: Thomas Gleixner <tglx@xxxxxxxxxxxxx>

 

--
To unsubscribe, send a message with 'unsubscribe linux-mm' in
the body to majordomo@xxxxxxxxx.  For more info on Linux MM,
see: http://www.linux-mm.org/ .
Don't email: <a href=mailto:"dont@xxxxxxxxx";> email@xxxxxxxxx </a>




[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Bugtraq]     [Linux]     [Linux OMAP]     [Linux MIPS]     [ECOS]     [Asterisk Internet PBX]     [Linux API]