On Wed 07-05-14 12:15:30, Vladimir Davydov wrote: > Current names are rather inconsistent. Let's try to improve them. Yes the old names are a giant mess. I am not sure the new ones are that much better however. > Brief change log: > > ** old name ** ** new name ** > > kmem_cache_create_memcg kmem_cache_request_memcg_copy Both are bad because the first suggests we are creating memcg and the second that we are requesting a copy of memcg. memcg_alloc_kmem_cache? _copy suffix is a bit confusing. E.g. copy_mm and others either to shallow or deep copy depending on the context. This one always creats a deep copy. Also why it is imporatant to treat the created caches as copies? > memcg_kmem_create_cache memcg_copy_kmem_cache memcg_register_kmem_cache? It also allocates so this name is a bit awkward as well. > memcg_kmem_destroy_cache memcg_destroy_kmem_cache_copy memcg_unregister_kmem_cache to match the above? > __kmem_cache_destroy_memcg_children __kmem_cache_destroy_memcg_copies > kmem_cache_destroy_memcg_children kmem_cache_destroy_memcg_copies _children suffix is really confusing because they have different meaning in memcg and refer to children groups. memcg_cleanup_kmem_chache_memcg_params? It doesn't have to live in the kmem_cache namespace because it only does only memcg kmem specific stuff. > mem_cgroup_destroy_all_caches memcg_destroy_kmem_cache_copies > > create_work memcg_kmem_cache_copy_work memcg_register_cache_work? > memcg_create_cache_work_func memcg_kmem_cache_copy_work_func memcg_register_cache_func? > memcg_create_cache_enqueue memcg_schedule_kmem_cache_copy memcg_schedule_register_cache? -- Michal Hocko SUSE Labs -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>