On Fri, 14 Feb 2014, Christoph Lameter wrote: > > @@ -215,9 +215,9 @@ static inline void set_obj_pfmemalloc(void **objp) > > return; > > } > > > > -static inline void clear_obj_pfmemalloc(void **objp) > > +static inline void *clear_obj_pfmemalloc(void *objp) > > { > > - *objp = (void *)((unsigned long)*objp & ~SLAB_OBJ_PFMEMALLOC); > > + return (void *)((unsigned long)objp & ~SLAB_OBJ_PFMEMALLOC); > > } > > I dont think you need the (void *) cast here. > Yeah, you don't need it, but don't you think it makes the code more readable? Otherwise this is going to be just doing return (unsigned long)objp & ~SLAB_OBJ_PFMEMALLOC; and you gotta figure out the function type to understand it's returned as a pointer. -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>