On Thu, 16 Jan 2014, Philipp Hachtmann wrote: > diff --git a/mm/nobootmem.c b/mm/nobootmem.c > index e2906a5..12cbb04 100644 > --- a/mm/nobootmem.c > +++ b/mm/nobootmem.c > @@ -116,9 +116,13 @@ static unsigned long __init __free_memory_core(phys_addr_t start, > static unsigned long __init free_low_memory_core_early(void) > { > unsigned long count = 0; > - phys_addr_t start, end, size; > + phys_addr_t start, end; > u64 i; > > +#ifdef CONFIG_ARCH_DISCARD_MEMBLOCK > + phys_addr_t size; > +#endif > + > for_each_free_mem_range(i, NUMA_NO_NODE, &start, &end, NULL) > count += __free_memory_core(start, end); > Two options: (1) add a helper function declared for CONFIG_ARCH_DISCARD_MEMBLOCK that returns the count to add and is empty otherwise, or (2) initialize size to zero in its definition. It's much better than #ifdef's inside the function for a variable declaration. Also, since this is already in -mm, you'll want this fix folded into the original patch, "mm/nobootmem: free_all_bootmem again", so it's probably best to name it "mm/nobootmem: free_all_bootmem again fix". -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>