On 11/21/2013 01:43 PM, Luiz Capitulino wrote: > @@ -655,9 +655,7 @@ restart: > void * __init __alloc_bootmem_nopanic(unsigned long size, unsigned long align, > unsigned long goal) > { > - unsigned long limit = 0; > - > - return ___alloc_bootmem_nopanic(size, align, goal, limit); > + return ___alloc_bootmem_nopanic(size, align, goal, 0); > } FWIW, I like those. The way you leave it: return ___alloc_bootmem_nopanic(size, align, goal, 0); the 0 is a magic number that you have to go look up the declaration of ___alloc_bootmem_nopanic() to decipher, or you have to add a comment to it in some way. I find it much more readable to have an 'unused' variable like that. -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>