This seems somewhat insane: int install_special_mapping(struct mm_struct *mm, unsigned long addr, unsigned long len, + unsigned long vm_flags, struct page **pages, + struct vm_area_struct **vma_prealloc) { + int ret = 0; + struct vm_area_struct *vma = *vma_prealloc; (removed the "old" lines to make it more readable). Why pass in "struct vm_area_struct **vma_prealloc" when you could just pass in a plain and more readable "struct vm_area_struct *vma"? My *guess* is that you originally cleared the vma_prealloc thing if you used it, but in the patch you sent out you definitely don't (the _only_ use of that "vma_prealloc" is the line that loads the content into "vma", so this interface looks like it is some remnant of an earlier and more complicated patch? Linus -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>