On Wed, Oct 16, 2013 at 03:27:54PM +0000, Christoph Lameter wrote: > On Wed, 16 Oct 2013, Joonsoo Kim wrote: > > > --- a/mm/slab.c > > +++ b/mm/slab.c > > @@ -930,7 +930,8 @@ static void *__ac_put_obj(struct kmem_cache *cachep, struct array_cache *ac, > > { > > if (unlikely(pfmemalloc_active)) { > > /* Some pfmemalloc slabs exist, check if this is one */ > > - struct page *page = virt_to_head_page(objp); > > + struct slab *slabp = virt_to_slab(objp); > > + struct page *page = virt_to_head_page(slabp->s_mem); > > if (PageSlabPfmemalloc(page)) > > I hope the compiler optimizes this code correctly because virt_to_slab > already does one virt_to_head_page()? It should not. objp could be in a different page with slabp->s_mem's, so virt_to_head_page() should be called twice. Anyway, after implementing struct slab overloading, one call site is removed by [14/15] in this patchset, so there is no issue. Thanks. > > Otherwise this looks fine. > > -- > To unsubscribe, send a message with 'unsubscribe linux-mm' in > the body to majordomo@xxxxxxxxx. For more info on Linux MM, > see: http://www.linux-mm.org/ . > Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a> -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>