On Wed 02-10-13 12:28:11, KOSAKI Motohiro wrote: > (10/2/13 10:27 AM), Jan Kara wrote: > > Provide a wrapper for get_user_pages() which takes care of acquiring and > > releasing mmap_sem. Using this function reduces amount of places in > > which we deal with mmap_sem. > > > > Signed-off-by: Jan Kara <jack@xxxxxxx> > > --- > > include/linux/mm.h | 14 ++++++++++++++ > > 1 file changed, 14 insertions(+) > > > > diff --git a/include/linux/mm.h b/include/linux/mm.h > > index 8b6e55ee8855..70031ead06a5 100644 > > --- a/include/linux/mm.h > > +++ b/include/linux/mm.h > > @@ -1031,6 +1031,20 @@ long get_user_pages(struct task_struct *tsk, struct mm_struct *mm, > > struct vm_area_struct **vmas); > > int get_user_pages_fast(unsigned long start, int nr_pages, int write, > > struct page **pages); > > +static inline long > > +get_user_pages_unlocked(struct task_struct *tsk, struct mm_struct *mm, > > + unsigned long start, unsigned long nr_pages, > > + int write, int force, struct page **pages) > > +{ > > + long ret; > > + > > + down_read(&mm->mmap_sem); > > + ret = get_user_pages(tsk, mm, start, nr_pages, write, force, pages, > > + NULL); > > + up_read(&mm->mmap_sem); > > + return ret; > > +} > > Hmmm. I like the idea, but I really dislike this name. I don't like xx_unlocked > function takes a lock. It is a source of confusing, I believe. Sure, I'm not very happy about the name either. As Christoph wrote probably renaming all get_user_pages() variants might be appropriate. I'll think about names some more. Honza -- Jan Kara <jack@xxxxxxx> SUSE Labs, CR -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>