On Tue, Oct 01, 2013 at 07:45:08PM +0200, Oleg Nesterov wrote: > On 10/01, Peter Zijlstra wrote: > > > > On Tue, Oct 01, 2013 at 10:41:15PM +0530, Srivatsa S. Bhat wrote: > > > However, as Oleg said, its definitely worth considering whether this proposed > > > change in semantics is going to hurt us in the future. CPU_POST_DEAD has certainly > > > proved to be very useful in certain challenging situations (commit 1aee40ac9c > > > explains one such example), so IMHO we should be very careful not to undermine > > > its utility. > > > > Urgh.. crazy things. I've always understood POST_DEAD to mean 'will be > > called at some time after the unplug' with no further guarantees. And my > > patch preserves that. > > I tend to agree with Srivatsa... Without a strong reason it would be better > to preserve the current logic: "some time after" should not be after the > next CPU_DOWN/UP*. But I won't argue too much. Nah, I think breaking it is the right thing :-) > But note that you do not strictly need this change. Just kill cpuhp_waitcount, > then we can change cpu_hotplug_begin/end to use xxx_enter/exit we discuss in > another thread, this should likely "join" all synchronize_sched's. That would still be 4k * sync_sched() == terribly long. > Or split cpu_hotplug_begin() into 2 helpers which handle FAST -> SLOW and > SLOW -> BLOCK transitions, then move the first "FAST -> SLOW" handler outside > of for_each_online_cpu(). Right, that's more messy but would work if we cannot teach cpufreq (and possibly others) to not rely on state you shouldn't rely on anyway. I tihnk the only guarnatee POST_DEAD should have is that it should be called before UP_PREPARE of the same cpu ;-) Nothing more, nothing less. -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>