Re: [PATCH 3/9] mm, hugetlb: clean-up alloc_huge_page()

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Mon 15-07-13 18:52:41, Joonsoo Kim wrote:
> We can unify some codes for succeed allocation.
> This makes code more readable.
> There is no functional difference.

"This patch unifies successful allocation paths to make the code more
readable. There are no functional changes."

Better?

> Signed-off-by: Joonsoo Kim <iamjoonsoo.kim@xxxxxxx>

Acked-by: Michal Hocko <mhocko@xxxxxxx>

> 
> diff --git a/mm/hugetlb.c b/mm/hugetlb.c
> index d21a33a..0067cf4 100644
> --- a/mm/hugetlb.c
> +++ b/mm/hugetlb.c
> @@ -1144,29 +1144,25 @@ static struct page *alloc_huge_page(struct vm_area_struct *vma,
>  		hugepage_subpool_put_pages(spool, chg);
>  		return ERR_PTR(-ENOSPC);
>  	}
> +
>  	spin_lock(&hugetlb_lock);
>  	page = dequeue_huge_page_vma(h, vma, addr, avoid_reserve);
> -	if (page) {
> -		/* update page cgroup details */
> -		hugetlb_cgroup_commit_charge(idx, pages_per_huge_page(h),
> -					     h_cg, page);
> -		spin_unlock(&hugetlb_lock);
> -	} else {
> +	if (!page) {
>  		spin_unlock(&hugetlb_lock);
>  		page = alloc_buddy_huge_page(h, NUMA_NO_NODE);
>  		if (!page) {
>  			hugetlb_cgroup_uncharge_cgroup(idx,
> -						       pages_per_huge_page(h),
> -						       h_cg);
> +						pages_per_huge_page(h), h_cg);
>  			hugepage_subpool_put_pages(spool, chg);
>  			return ERR_PTR(-ENOSPC);
>  		}
> +
>  		spin_lock(&hugetlb_lock);
> -		hugetlb_cgroup_commit_charge(idx, pages_per_huge_page(h),
> -					     h_cg, page);
>  		list_move(&page->lru, &h->hugepage_activelist);
> -		spin_unlock(&hugetlb_lock);
> +		/* Fall through */
>  	}
> +	hugetlb_cgroup_commit_charge(idx, pages_per_huge_page(h), h_cg, page);
> +	spin_unlock(&hugetlb_lock);
>  
>  	set_page_private(page, (unsigned long)spool);
>  
> -- 
> 1.7.9.5
> 

-- 
Michal Hocko
SUSE Labs

--
To unsubscribe, send a message with 'unsubscribe linux-mm' in
the body to majordomo@xxxxxxxxx.  For more info on Linux MM,
see: http://www.linux-mm.org/ .
Don't email: <a href=mailto:"dont@xxxxxxxxx";> email@xxxxxxxxx </a>




[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Bugtraq]     [Linux]     [Linux OMAP]     [Linux MIPS]     [ECOS]     [Asterisk Internet PBX]     [Linux API]