On 01:05 Thu 16 May , Andrew Morton wrote: > On Mon, 13 May 2013 16:16:33 +0200 Oskar Andero <oskar.andero@xxxxxxxxxxxxxx> wrote: > > > In a previous discussion on lkml it was noted that the shrinkers use the > > magic value "-1" to signal that something went wrong. > > > > This patch-set implements the suggestion of instead using errno.h values > > to return something more meaningful. > > > > The first patch simply changes the check from -1 to any negative value and > > updates the comment accordingly. > > > > The second patch updates the shrinkers to return an errno.h value instead > > of -1. Since this one spans over many different areas I need input on what is > > a meaningful return value. Right now I used -EBUSY on everything for consitency. > > > > What do you say? Is this a good idea or does it make no sense at all? > > I don't see much point in it, really. Returning an errno implies that > the errno will eventually be returned to userspace. But that isn't the > case, so such a change is somewhat misleading. Yes. Glauber Costa pointed that out and I agree - errno.h is probably not the right way to go. > If we want the capability to return more than a binary yes/no message > to callers then yes, we could/should enumerate the shrinker return > values. But as that is a different concept from errnos, it should be > done with a different and shrinker-specific namespace. Agreed, but even if there right now is only a binary return message, is a hardcoded -1 considered to be acceptable for an interface? IMHO, it is not very readable nor intuitive for the users of the interface. Why not, as you mention, add a define or enum in shrinker.h instead, e.g. SHRINKER_STOP or something. -Oskar -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>