Mel Gorman <mgorman@xxxxxxx> writes: > @@ -495,6 +495,9 @@ typedef enum { > ZONE_CONGESTED, /* zone has many dirty pages backed by > * a congested BDI > */ > + ZONE_DIRTY, /* reclaim scanning has recently found > + * many dirty file pages > + */ Needs a better name. ZONE_DIRTY_CONGESTED ? > + * currently being written then flag that kswapd should start > + * writing back pages. > + */ > + if (global_reclaim(sc) && nr_dirty && > + nr_dirty >= (nr_taken >> (DEF_PRIORITY - sc->priority))) > + zone_set_flag(zone, ZONE_DIRTY); > + > trace_mm_vmscan_lru_shrink_inactive(zone->zone_pgdat->node_id, I suppose you want to trace the dirty case here too. -Andi -- ak@xxxxxxxxxxxxxxx -- Speaking for myself only -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>