On Tue, Feb 05, 2013 at 06:26:51PM -0800, Michel Lespinasse wrote: > Just nitpicking, but: > > On Tue, Feb 5, 2013 at 3:57 AM, Mel Gorman <mgorman@xxxxxxx> wrote: > > +static inline bool zone_is_idx(struct zone *zone, enum zone_type idx) > > +{ > > + /* This mess avoids a potentially expensive pointer subtraction. */ > > + int zone_off = (char *)zone - (char *)zone->zone_pgdat->node_zones; > > + return zone_off == idx * sizeof(*zone); > > +} > > Maybe: > return zone == zone->zone_pgdat->node_zones + idx; > ? > Not a nit at all. Yours is more readable but it generates more code. A single line function that uses the helper generates 0x3f bytes of code (mostly function entry/exit) with your version and 0x39 bytes with mine. The difference in efficiency is marginal as your version uses lea to multiply by a constant but it's still slightly heavier. The old code is fractionally better, your version is more readable so it's up to Andrew really. Right now I think he's gone with his own version with zone_idx() in the name of readability whatever sparse has to say about the matter. -- Mel Gorman SUSE Labs -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>