On 01/15/2013 04:24 PM, Cody P Schafer wrote: > +static inline bool zone_spans_pfn(const struct zone *zone, unsigned long pfn) > +{ > + return zone->zone_start_pfn <= pfn && pfn < zone_end_pfn(zone); > +} This needs some parenthesis, just for readability. There's also no crime in breaking it up to be multi-line if you want. > +static inline bool zone_is_initialized(struct zone *zone) > +{ > + return !!zone->wait_table; > +} > + > +static inline bool zone_is_empty(struct zone *zone) > +{ > + return zone->spanned_pages == 0; > +} -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>