On Tue, Dec 04, 2012 at 09:42:55AM -0500, Jeff Moyer wrote: > Dave Chinner <david@xxxxxxxxxxxxx> writes: > > > On Mon, Dec 03, 2012 at 01:53:39PM -0500, Jeff Moyer wrote: > >> +static ssize_t cpu_list_store(struct device *dev, > >> + struct device_attribute *attr, const char *buf, size_t count) > >> +{ > >> + struct backing_dev_info *bdi = dev_get_drvdata(dev); > >> + struct bdi_writeback *wb = &bdi->wb; > >> + cpumask_var_t newmask; > >> + ssize_t ret; > >> + struct task_struct *task; > >> + > >> + if (!alloc_cpumask_var(&newmask, GFP_KERNEL)) > >> + return -ENOMEM; > >> + > >> + ret = cpulist_parse(buf, newmask); > >> + if (!ret) { > >> + spin_lock(&bdi->wb_lock); > >> + task = wb->task; > >> + if (task) > >> + get_task_struct(task); > >> + spin_unlock(&bdi->wb_lock); > >> + if (task) { > >> + ret = set_cpus_allowed_ptr(task, newmask); > >> + put_task_struct(task); > >> + } > > > > Why is this set here outside the bdi->flusher_cpumask_mutex? > > The cpumask mutex protects updates to bdi->flusher_cpumask, it has > nothing to do with the call to set_cpus_allowed. We are protected from > concurrent calls to cpu_list_store by the sysfs mutex that is taken on > entry. I understand that this is non-obvious, and it wouldn't be wrong > to hold the mutex here. If you'd like me to do that for clarity, that > would be ok with me. At minimum it needs a comment like this otherwise someone is going to come along and ask "why is that safe?" like I just did. I'd prefer the code to be obviously consistent to avoid the need for commenting about the special case, especially when the obviously correct code is simpler ;) Cheers, Dave. -- Dave Chinner david@xxxxxxxxxxxxx -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>