On Wed, Nov 7, 2012 at 11:48 AM, Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> wrote: >> >> Firstly, the patch follows the policy in the system suspend/resume situation, >> in which the __GFP_FS is cleared, and basically the problem is very similar >> with that in system PM path. > > I suspect that code is wrong. Or at least, suboptimal. > >> Secondly, inside shrink_page_list(), pageout() may be triggered on dirty anon >> page if __GFP_FS is set. > > pageout() should be called if GFP_FS is set or if GFP_IO is set and the > IO is against swap. > > And that's what we want to happen: we want to enter the fs to try to > turn dirty pagecache into clean pagecache without doing IO. If we in > fact enter the device drivers when GFP_IO was not set then that's a bug > which we should fix. OK, I got it, and I'll not clear GFP_FS in -v5. > >> IMO, if performing I/O can be completely avoided when __GFP_FS is set, the >> flag can be kept, otherwise it is better to clear it in the situation. > > yup. > >> > >> > Also, you can probably put the unlikely() inside memalloc_noio() and >> > avoid repeating it at all the callsites. >> > >> > And it might be neater to do: >> > >> > /* >> > * Nice comment goes here >> > */ >> > static inline gfp_t memalloc_noio_flags(gfp_t flags) >> > { >> > if (unlikely(current->flags & PF_MEMALLOC_NOIO)) >> > flags &= ~GFP_IOFS; >> > return flags; >> > } >> >> But without the check in callsites, some local variables will be write >> two times, >> so it is better to not do it. > > I don't see why - we just modify the incoming gfp_t at the start of the > function, then use it. > > It gets a bit tricky with those struct initialisations. Things like > > struct foo bar { > .a = a1, > .b = b1, > }; > > should not be turned into > > struct foo bar { > .a = a1, > }; > > bar.b = b1; > > and we don't want to do > > struct foo bar { }; > > bar.a = a1; > bar.b = b1; > > either, because these are indeed a double-write. But we can do > > struct foo bar { > .flags = (flags = memalloc_noio_flags(flags)), > .b = b1, > }; > > which is a bit arcane but not toooo bad. Have a think about it... Got it, looks memalloc_noio_flags() neater, and I will take it in v5. Thanks, -- Ming Lei -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>